summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBill Nottingham <notting@redhat.com>2010-10-28 13:27:44 -0400
committerLennart Poettering <lennart@poettering.net>2010-10-29 16:28:28 +0200
commit73d35ff8e475d17a22fc524ae003553021acaa8e (patch)
tree162304856795f4508aa0396b6a337e9180a6cfc4 /Makefile.am
parent9524600eac7c45a8e4b9f426020e24ccfc150d41 (diff)
Fedora: further unit tweaks
1) Just ship rc-local as-is; don't worry about the 'local' name. 2) Don't install rc-local and prefdm to /etc ; just enable them globally for the system in /lib.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 4 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 56bafdc09..3c65febb5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1175,13 +1175,10 @@ if TARGET_FEDORA
$(DESTDIR)$(systemunitdir)/rescue.target.wants \
$(DESTDIR)$(systemunitdir)/multi-user.target.wants \
$(DESTDIR)$(systemunitdir)/final.target.wants
- ( cd $(DESTDIR)$(pkgsysconfdir)/system && \
- rm -f display-manager.service && \
- $(LN_S) $(systemunitdir)/prefdm.service display-manager.service )
- ( cd $(DESTDIR)$(pkgsysconfdir)/system/graphical.target.wants && \
+ ( cd $(DESTDIR)$(systemunitdir)/graphical.target.wants && \
rm -f prefdm.service && \
$(LN_S) $(systemunitdir)/prefdm.service prefdm.service )
- ( cd $(DESTDIR)$(pkgsysconfdir)/system/multi-user.target.wants && \
+ ( cd $(DESTDIR)$(systemunitdir)/multi-user.target.wants && \
rm -f rc-local.service && \
$(LN_S) $(systemunitdir)/rc-local.service rc-local.service )
( cd $(DESTDIR)$(systemunitdir)/final.target.wants && \
@@ -1204,8 +1201,8 @@ if TARGET_FEDORA
rm -f plymouth-halt.service && \
$(LN_S) ../plymouth-halt.service plymouth-halt.service )
( cd $(DESTDIR)$(systemunitdir) && \
- rm -f local.service && \
- $(LN_S) rc-local.service local.service )
+ rm -f display-manager.service && \
+ $(LN_S) prefdm.service display-manager.service )
endif
if TARGET_GENTOO
( cd $(DESTDIR)$(pkgsysconfdir)/system && \