summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-20 17:58:35 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-20 19:48:16 -0400
commit8b835fccdad78d89f9cc64f9b02059fb75ffbab1 (patch)
treecee036287462e1c2d8454f3419a671a64ee853a9 /Makefile.am
parentcf7d80a5fe549d4db11800015e02220dccec3096 (diff)
systemd-verify: a simple tool for offline unit verification
This tool will warn about misspelt directives, unknown sections, and non-executable commands. It will also catch the common mistake of using Accept=yes with a non-template unit and vice versa. https://bugs.freedesktop.org/show_bug.cgi?id=56607
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 91ecbe4a0..1e4cfb31f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -350,7 +350,8 @@ bin_PROGRAMS = \
systemd-delta \
systemd-analyze \
systemd-run \
- systemd-path
+ systemd-path \
+ systemd-verify
dist_bin_SCRIPTS = \
src/kernel-install/kernel-install
@@ -1224,6 +1225,20 @@ CLEANFILES += \
src/core/org.freedesktop.systemd1.policy.in
# ------------------------------------------------------------------------------
+
+systemd_verify_SOURCES = \
+ src/verify/verify.c
+
+systemd_verify_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(SECCOMP_CFLAGS)
+
+systemd_verify_LDADD = \
+ libsystemd-core.la \
+ $(RT_LIBS)
+
+# ------------------------------------------------------------------------------
+
manual_tests += \
test-ns \
test-loopback \