summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Scherer <misc@zarb.org>2014-02-20 16:07:08 +0100
committerLennart Poettering <lennart@poettering.net>2014-02-21 03:10:09 +0100
commit8eea53dd45265d8cb92bfdb161a425a1668c10c0 (patch)
treeae9a4066f2af8daa40ae16f62a86826dfb9eed8e /Makefile.am
parent6633045578722be838ba5e40632379f79e5f4954 (diff)
build-sys: Fix compilation of nspawn when seccomp is not enabled
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 85d51b4a9..56cdb8568 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1882,9 +1882,13 @@ systemd_nspawn_LDADD = \
libsystemd-capability.la \
libsystemd-internal.la \
libudev-internal.la \
- libsystemd-shared.la \
+ libsystemd-shared.la
+
+if HAVE_SECCOMP
+systemd_nspawn_LDADD += \
libsystemd-seccomp.la \
$(SECCOMP_LIBS)
+endif
# ------------------------------------------------------------------------------
systemd_run_SOURCES = \