summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2014-07-29 16:44:04 +0200
committerKay Sievers <kay@vrfy.org>2014-07-29 16:58:18 +0200
commit94a15ffa14b8272e827f4cf95244910839a9d907 (patch)
tree1bf49b1bd7636933fdafb78acbe4a1a701578ce0 /Makefile.am
parent9ec6e95b046de71c0198cb9d17acc5462dc76c74 (diff)
factory: install minimal PAM and nsswitch config
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cd3a2d747..9f2900cb6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,6 +106,8 @@ udevrulesdir=$(udevlibexecdir)/rules.d
udevhwdbdir=$(udevlibexecdir)/hwdb.d
catalogdir=$(prefix)/lib/systemd/catalog
kernelinstalldir = $(prefix)/lib/kernel/install.d
+factory_etcdir = $(prefix)/share/factory/etc
+factory_pamdir = $(prefix)/share/factory/etc/pam.d
# And these are the special ones for /
rootprefix=@rootprefix@
@@ -1928,6 +1930,14 @@ INSTALL_DIRS += \
endif
# ------------------------------------------------------------------------------
+dist_factory_etc_DATA = \
+ factory/etc/nsswitch.conf
+
+dist_factory_pam_DATA = \
+ factory/etc/pam.d/system-auth \
+ factory/etc/pam.d/other
+
+# ------------------------------------------------------------------------------
if ENABLE_FIRSTBOOT
systemd_firstboot_SOURCES = \
src/firstboot/firstboot.c
@@ -1951,7 +1961,6 @@ EXTRA_DIST += \
SYSINIT_TARGET_WANTS += \
systemd-firstboot.service
-
endif
# ------------------------------------------------------------------------------