summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2014-02-04 23:13:52 +0100
committerTom Gundersen <teg@jklm.no>2014-02-07 15:48:35 +0100
commita6cc569e33a05b07550c6c7b4d67d83d868f8bc1 (patch)
tree5b8754fa594896f79ba4cb62772f6b1b49be4325 /Makefile.am
parentd72143bad46b51fc0bbedf01ff92aea8b07afac6 (diff)
sd-dhcp-client: split sd_dhcp_lease from sd_dhcp_client
This allows us users of the library to keep copies of old leases. This is used by networkd to know what addresses to drop (if any) when the lease expires. In the future this may be used by DNAv4 and sd-dhcp-server.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8af29d160..4f5e03699 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2345,6 +2345,8 @@ noinst_LTLIBRARIES += \
libsystemd_dhcp_la_SOURCES = \
src/systemd/sd-dhcp-client.h \
src/libsystemd-dhcp/sd-dhcp-client.c \
+ src/libsystemd-dhcp/dhcp-lease.h \
+ src/libsystemd-dhcp/dhcp-lease.c \
src/libsystemd-dhcp/dhcp-network.c \
src/libsystemd-dhcp/dhcp-option.c \
src/libsystemd-dhcp/dhcp-internal.h \