summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRonny Chevalier <chevalier.ronny@gmail.com>2014-08-16 14:19:10 +0200
committerLennart Poettering <lennart@poettering.net>2014-08-18 18:43:58 +0200
commitb08f2be60aceb0c260fb232b9e8b950f0c871cb9 (patch)
tree89738ee5f2a49ebbfff2b0bf4178903f5c9e9579 /Makefile.am
parent8852362bfc39a3e3bcad9a3287a61ff6587369ef (diff)
tests: add test-condition-util
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b9deaa653..3ef9c2431 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1321,7 +1321,8 @@ tests += \
test-conf-files \
test-capability \
test-async \
- test-ratelimit
+ test-ratelimit \
+ test-condition-util
EXTRA_DIST += \
test/a.service \
@@ -1460,6 +1461,14 @@ test_async_SOURCES = \
test_async_LDADD = \
libsystemd-shared.la
+test_condition_util_SOURCES = \
+ src/test/test-condition-util.c
+
+test_condition_util_LDADD = \
+ libsystemd-shared.la \
+ libsystemd-internal.la
+
+
test_fdset_SOURCES = \
src/test/test-fdset.c