summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-11-27 01:01:53 +0100
committerLennart Poettering <lennart@poettering.net>2013-11-27 01:01:53 +0100
commitd0767ffd08bbb5c069e266710eb0462315e47e6d (patch)
tree6e404303074be046bc0b0da2efa11ca84288ddf7 /Makefile.am
parent248c78c79c5cca9b981800d816a77591e504066a (diff)
journal: add a test case for flushing messages out of a series of journal files into a single new one
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 47c269def..0119751c4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2961,6 +2961,12 @@ test_journal_stream_SOURCES = \
test_journal_stream_LDADD = \
libsystemd-journal-core.la
+test_journal_flush_SOURCES = \
+ src/journal/test-journal-flush.c
+
+test_journal_flush_LDADD = \
+ libsystemd-journal-core.la
+
test_journal_init_SOURCES = \
src/journal/test-journal-init.c
@@ -3167,6 +3173,7 @@ tests += \
test-journal-init \
test-journal-verify \
test-journal-interleaving \
+ test-journal-flush \
test-mmap-cache \
test-catalog