summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2014-02-03 15:25:45 +0100
committerTom Gundersen <teg@jklm.no>2014-02-03 15:25:45 +0100
commite59749b1f8a960060b7b8e850cc79f97ddaf2db4 (patch)
tree2046ece705680361ac33772ef049475f08560947 /Makefile.am
parent486e99a387adec15738c2822c2df5c813955f433 (diff)
build-sys: move -lresolv out of CFLAGS
Thomas H.P. Andersen <phomes@gmail.com> wrote: > Does -lresolv belong in libsystemd_la_CFLAGS? I would have thought > that it should be in LIBADD for the lib and LDADD for the test.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 84e3b35fa..8af29d160 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2039,12 +2039,12 @@ nodist_libsystemd_la_SOURCES = \
libsystemd_la_LIBADD = \
libsystemd-daemon-internal.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ -lresolv
libsystemd_la_CFLAGS = \
$(AM_CFLAGS) \
- -pthread \
- -lresolv
+ -pthread
libsystemd_la_LDFLAGS = \
$(AM_LDFLAGS) \
@@ -2316,7 +2316,8 @@ test_resolve_SOURCES = \
test_resolve_LDADD = \
libsystemd-internal.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ -lresolv
test_resolve_CFLAGS = \
$(AM_CFLAGS) \