summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-31 04:19:43 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-07-31 08:56:03 -0400
commit0dae31d468b1a0e22d98921f7b0dbd92fd217167 (patch)
tree0b1b2c51eab8bc4dc474b5fd1b3777abf64ed85c /Makefile.am
parent9de3e3294065e8697ff10130b53f274319cdcf6f (diff)
resolved: LOC records
LOC records have a version field. So far only version 0 has been published, but if a record with a different version was encountered, our only recourse is to treat it as an unknown type. This is implemented with the 'unparseable' flag, which causes the serialization/deserialization and printing function to cause the record as a blob. The flag can be used if other packet types cannot be parsed for whatever reason.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e982f506..94eeb114a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4775,7 +4775,8 @@ systemd_resolved_LDADD = \
libsystemd-network.la \
libsystemd-label.la \
libsystemd-internal.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ -lm
rootlibexec_PROGRAMS += \
systemd-resolved
@@ -4863,7 +4864,8 @@ systemd_resolve_host_SOURCES = \
systemd_resolve_host_LDADD = \
libsystemd-internal.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ -lm
rootlibexec_PROGRAMS += \
systemd-resolve-host