summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2016-12-30 15:43:50 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:18:27 +0100
commit1532f28b7cf3e6e02e74691450b2b5379be6b805 (patch)
tree184d2f253b46da8658037e51c1670122983a32c8 /Makefile.am
parent37570c53dc8865f07ae8ff5a9915d7ed797b951f (diff)
Prep v222: Update build system:
- The content of the man pages directory has been overhauled - Makefile-man.am was regenerated - Makefile.am and configure.ac needed a few addtitions and fixes - Some masked functions had to be unmasked - Now superfluous files have been removed
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am45
1 files changed, 42 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1cb1c2063..639fd577a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,9 +38,9 @@ SUBDIRS = . po
# Keep the test-suite.log
.PRECIOUS: $(TEST_SUITE_LOG) Makefile
-LIBELOGIND_CURRENT=8
-LIBELOGIND_REVISION=0
-LIBELOGIND_AGE=8
+LIBELOGIND_CURRENT=9
+LIBELOGIND_REVISION=3
+LIBELOGIND_AGE=9
# Dirs of external packages
dbuspolicydir=@dbuspolicydir@
@@ -241,6 +241,45 @@ noinst_DATA += \
CLEANFILES += \
docs/html/man
+if HAVE_PYTHON
+man/index.html: man/systemd.index.html
+ $(AM_V_LN)$(LN_S) -f systemd.index.html $@
+
+noinst_DATA += \
+ man/index.html
+
+CLEANFILES += \
+ man/index.html
+
+XML_GLOB = $(wildcard $(top_srcdir)/man/*.xml)
+NON_INDEX_XML_FILES = $(filter-out man/systemd.index.xml,$(XML_FILES))
+SOURCE_XML_FILES = ${patsubst %,$(top_srcdir)/%,$(filter-out man/systemd.directives.xml,$(NON_INDEX_XML_FILES))}
+
+# This target should only be run manually. It recreates Makefile-man.am
+# file in the source directory based on all man/*.xml files. Run it after
+# adding, removing, or changing the conditional in a man page.
+update-man-list: $(top_srcdir)/tools/make-man-rules.py $(XML_GLOB)
+ $(AM_V_GEN)$(PYTHON) $^ > $(top_srcdir)/Makefile-man.tmp
+ $(AM_V_at)mv $(top_srcdir)/Makefile-man.tmp $(top_srcdir)/Makefile-man.am
+ @echo "Makefile-man.am has been regenerated"
+
+man/systemd.index.xml: $(top_srcdir)/tools/make-man-index.py $(NON_INDEX_XML_FILES)
+ $(AM_V_at)$(MKDIR_P) $(dir $@)
+ $(AM_V_GEN)$(PYTHON) $< $@ $(filter-out $<,$^)
+
+man/systemd.directives.xml: $(top_srcdir)/tools/make-directive-index.py man/custom-entities.ent $(SOURCE_XML_FILES)
+ $(AM_V_at)$(MKDIR_P) $(dir $@)
+ $(AM_V_GEN)$(PYTHON) $< $@ $(SOURCE_XML_FILES)
+
+CLEANFILES += \
+ man/systemd.index.xml \
+ man/systemd.directives.xml
+
+EXTRA_DIST += \
+ tools/make-man-rules.py
+
+endif
+
endif
EXTRA_DIST += \