summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Mack <daniel@zonque.org>2014-09-19 14:50:53 +0200
committerDaniel Mack <daniel@zonque.org>2014-09-20 18:47:45 +0200
commit20725d929ff566e53d7a857d6f0ee94aa8383469 (patch)
tree59f7ebbf70dc6f9f6c97b2382cb582a8953edd7f /Makefile.am
parent38349552d8d6418229fee9ee68b1f470b4ad7a52 (diff)
bus-policy: add test utility
Add some test files and routines for dbus policy checking.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 18 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f80ffc674..6b2ca29ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1342,7 +1342,8 @@ tests += \
test-async \
test-ratelimit \
test-condition-util \
- test-uid-range
+ test-uid-range \
+ test-bus-policy
EXTRA_DIST += \
test/a.service \
@@ -1374,7 +1375,12 @@ EXTRA_DIST += \
test/sysinit.target \
test/testsuite.target \
test/timers.target \
- test/unstoppable.service
+ test/unstoppable.service \
+ test/bus-policy/hello.conf \
+ test/bus-policy/methods.conf \
+ test/bus-policy/ownerships.conf \
+ test/bus-policy/signals.conf
+
EXTRA_DIST += \
src/test/test-helper.h
@@ -1782,6 +1788,16 @@ test_conf_files_SOURCES = \
test_conf_files_LDADD = \
libsystemd-shared.la
+test_bus_policy_SOURCES = \
+ src/bus-proxyd/test-bus-policy.c \
+ src/bus-proxyd/bus-policy.c \
+ src/bus-proxyd/bus-policy.h
+
+test_bus_policy_LDADD = \
+ libsystemd-capability.la \
+ libsystemd-internal.la \
+ libsystemd-shared.la
+
# ------------------------------------------------------------------------------
## .PHONY so it always rebuilds it
.PHONY: coverage lcov-run lcov-report coverage-sync