summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2015-03-09 17:55:07 +0100
committerLennart Poettering <lennart@poettering.net>2015-03-09 18:02:23 +0100
commit587fec427c80b6c34dcf1d7570f891fcb652a7c5 (patch)
tree0b8f6e748ac8ecc34cbe6d03327532fb52a0e85b /Makefile.am
parentea79e73b8a8fa72fb959a0604f642f97e200a803 (diff)
importd: add API for exporting container/VM images
Also, expose it in machinectl.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 28 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 42183f45d..3539e03c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5371,7 +5371,8 @@ if HAVE_GCRYPT
rootlibexec_PROGRAMS += \
systemd-importd \
systemd-pull \
- systemd-import
+ systemd-import \
+ systemd-export
systemd_importd_SOURCES = \
src/import/importd.c
@@ -5379,7 +5380,8 @@ systemd_importd_SOURCES = \
systemd_importd_CFLAGS = \
$(AM_CFLAGS) \
-D SYSTEMD_PULL_PATH=\"$(rootlibexecdir)/systemd-pull\" \
- -D SYSTEMD_IMPORT_PATH=\"$(rootlibexecdir)/systemd-import\"
+ -D SYSTEMD_IMPORT_PATH=\"$(rootlibexecdir)/systemd-import\" \
+ -D SYSTEMD_EXPORT_PATH=\"$(rootlibexecdir)/systemd-export\"
systemd_importd_LDADD = \
libsystemd-internal.la \
@@ -5454,6 +5456,30 @@ systemd_import_LDADD = \
$(ZLIB_LIBS) \
-lbz2
+systemd_export_SOURCES = \
+ src/import/export.c \
+ src/import/export-tar.c \
+ src/import/export-tar.h \
+ src/import/export-raw.c \
+ src/import/export-raw.h \
+ src/import/import-common.c \
+ src/import/import-common.h \
+ src/import/import-compress.c \
+ src/import/import-compress.h
+
+systemd_export_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(XZ_CFLAGS) \
+ $(ZLIB_CFLAGS)
+
+systemd_export_LDADD = \
+ libsystemd-internal.la \
+ libsystemd-label.la \
+ libsystemd-shared.la \
+ $(XZ_LIBS) \
+ $(ZLIB_LIBS) \
+ -lbz2
+
dist_rootlibexec_DATA = \
src/import/import-pubring.gpg