summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-06-02 11:18:12 +0200
committerSven Eden <yamakuzure@gmx.net>2017-06-16 10:12:58 +0200
commit7146d24aeaac6bf5a9f1fbe0c786a846410145ff (patch)
treeec9748506111138acb25fcb8e2da9ac978def7f8 /Makefile.am
parentcadc392ed7e51a99235c69a8006eeba208317ebe (diff)
Prep v230: Move installed headers
The headers are now installed into /usr/include/elogind/systemd and the pkg-config file now returns -I/usr/include/elogind for CFLAGS. Further /usr/include/elogind contains symlinks to the headers, so existing packages already including <elogind/sd-login.h> will not be broken. This way no software has to change their include lines anywhere to support elogind any more. All they have to do is either add LIBSYSTEMD_CFLAGS or LIBELOGIND_CFLAGS from pkg-config and be done with it. So most patching can be avoided, just some configure adaption is needed. However, this can lead to systemd/elogind bug confusion if there is anything mixed up on a system that shouldn't. Downstreams, chose any of the two ways to your own discretion! See https://bugs.freedesktop.org/show_bug.cgi?id=101251
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2305caff6..bf9082428 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,7 @@ PKTTYAGENT=$(bindir)/pkttyagent
# Our own, non-special dirs
pkgsysconfdir=$(sysconfdir)/elogind
-pkgincludedir=$(includedir)/elogind
+pkgincludedir=$(includedir)/elogind/systemd
udevrulesdir=@udevrulesdir@
udevbindir=@udevbindir@
udevlibexecdir=$(udevbindir)
@@ -625,6 +625,18 @@ pkginclude_HEADERS += \
src/systemd/sd-id128.h \
src/systemd/_sd-common.h
+header-install-hook:
+ $(MKDIR_P) $(DESTDIR)/$(pkgincludedir)
+ cd $(DESTDIR)/$(includedir)/elogind && \
+ for hdr in $(notdir $(pkginclude_HEADERS)) ; do \
+ $(LN_S) systemd/$$hdr $$hdr ; \
+ done
+
+header-uninstall-hook:
+ m -f $(DESTDIR)/$(includedir)/elogind/*.h
+
+INSTALL_EXEC_HOOKS += header-install-hook
+UNINSTALL_EXEC_HOOKS += header-uninstall-hook
lib_LTLIBRARIES += \
libelogind.la