summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@gmail.com>2014-09-19 14:48:54 +0200
committerDavid Herrmann <dh.herrmann@gmail.com>2014-09-19 14:48:54 +0200
commit810626a80de8361dfbe27110d585023b3d6167a6 (patch)
tree8d640f883d65c52d49e4f38d85579fa81bc1424f /Makefile.am
parentf22e0bce3732c1fd005b7a886042394e036bc1b3 (diff)
terminal: add systemd-modeset debugging tool
The systemd-modeset tool is meant to debug grdev issues. It simply displays morphing colors on any found display. This is pretty handy to look for tearing in the backends and debug hotplug issues. Note that this tool requires systemd-logind to be compiled from git (there're important fixes that haven't been released, yet).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index be25023c7..f80ffc674 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2987,6 +2987,7 @@ noinst_LTLIBRARIES += \
noinst_PROGRAMS += \
systemd-evcat \
+ systemd-modeset \
systemd-subterm
unifontdatadir=$(datadir)/unifont
@@ -3045,6 +3046,19 @@ systemd_evcat_LDADD = \
libsystemd-shared.la \
$(TERMINAL_LIBS)
+systemd_modeset_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(TERMINAL_CFLAGS)
+
+systemd_modeset_SOURCES = \
+ src/libsystemd-terminal/modeset.c
+
+systemd_modeset_LDADD = \
+ libsystemd-terminal.la \
+ libsystemd-internal.la \
+ libsystemd-shared.la \
+ $(TERMINAL_LIBS)
+
systemd_subterm_SOURCES = \
src/libsystemd-terminal/subterm.c