summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2015-03-05 00:56:08 +0100
committerLennart Poettering <lennart@poettering.net>2015-03-05 00:59:38 +0100
commitb6e676ce41508e2aeea22202fc8f234126177f52 (patch)
tree8fcf8bca4f59eaab91ef13909e0454cf1684c225 /Makefile.am
parent776a972612be7131ce6f7accd66e75ca7e0fce2a (diff)
importd: add new bus calls for importing local tar and raw images
This also adds "machinectl import-raw" and "machinectl import-tar" to wrap these new bus calls. THe commands basically do for local files that "machinectl pull-raw" and friends do for remote files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 32 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d430fff97..843a7df9e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5430,14 +5430,16 @@ if HAVE_GCRYPT
rootlibexec_PROGRAMS += \
systemd-importd \
- systemd-pull
+ systemd-pull \
+ systemd-import
systemd_importd_SOURCES = \
src/import/importd.c
systemd_importd_CFLAGS = \
$(AM_CFLAGS) \
- -D SYSTEMD_PULL_PATH=\"$(rootlibexecdir)/systemd-pull\"
+ -D SYSTEMD_PULL_PATH=\"$(rootlibexecdir)/systemd-pull\" \
+ -D SYSTEMD_IMPORT_PATH=\"$(rootlibexecdir)/systemd-import\"
systemd_importd_LDADD = \
libsystemd-internal.la \
@@ -5456,6 +5458,8 @@ systemd_pull_SOURCES = \
src/import/pull-job.h \
src/import/pull-common.c \
src/import/pull-common.h \
+ src/import/import-common.c \
+ src/import/import-common.h \
src/import/import-compress.c \
src/import/import-compress.h \
src/import/curl-util.c \
@@ -5484,6 +5488,32 @@ systemd_pull_LDADD = \
-lbz2 \
$(GCRYPT_LIBS)
+systemd_import_SOURCES = \
+ src/import/import.c \
+ src/import/import-raw.c \
+ src/import/import-raw.h \
+ src/import/import-tar.c \
+ src/import/import-tar.h \
+ src/import/import-common.c \
+ src/import/import-common.h \
+ src/import/import-compress.c \
+ src/import/import-compress.h \
+ src/import/qcow2-util.c \
+ src/import/qcow2-util.h
+
+systemd_import_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(XZ_CFLAGS) \
+ $(ZLIB_CFLAGS)
+
+systemd_import_LDADD = \
+ libsystemd-internal.la \
+ libsystemd-label.la \
+ libsystemd-shared.la \
+ $(XZ_LIBS) \
+ $(ZLIB_LIBS) \
+ -lbz2
+
dist_rootlibexec_DATA = \
src/import/import-pubring.gpg