summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichal Schmidt <mschmidt@redhat.com>2014-08-15 16:33:03 +0200
committerMichal Schmidt <mschmidt@redhat.com>2014-09-15 16:08:50 +0200
commitf44541bc934c6e2b02155559e9eeb17a13a09558 (patch)
tree25e6ffdd6fd15d5af6cf47ef37fac8e0af48927c /Makefile.am
parent20755373b1494f1b718b1ac3a611c6f807905fe6 (diff)
build: colorize gcc only if on tty
Rather than forcing gcc to always produce colorized error messages whether on tty or not, enable automatic colorization by ensuring GCC_COLORS is set to a non-empty string. Doing it this way removes the need for workarounds in ~/.emacs or ~/.vimrc for "M-x compile" or ":make", respectively, to work.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index de40043c5..5dc17f8fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,9 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
AM_MAKEFLAGS = --no-print-directory
AUTOMAKE_OPTIONS = color-tests parallel-tests
+GCC_COLORS ?= 'ooh, shiny!'
+export GCC_COLORS
+
SUBDIRS = . po
# remove targets if the command fails