summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2012-01-10 07:26:30 +0100
committerMichael Biebl <biebl@debian.org>2012-01-10 07:26:30 +0100
commit118ca5966f21c07ae8561f33da45b3810b32889a (patch)
tree4465df5a727af4d701cb664be5655490432080d6 /Makefile.am
parent7e4ab3c5a6295193d0c58d353b6430265d842f34 (diff)
build-sys: link systemctl and systemd-journalctl against libsystemd-id128
Both use logs-show.c which requires libsystemd-id128 for sd_id128_to_string ().
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f5cef3f89..2279ff48c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -974,6 +974,7 @@ systemctl_LDADD = \
libsystemd-basic.la \
libsystemd-daemon.la \
libsystemd-journal.la \
+ libsystemd-id128.la \
$(DBUS_LIBS)
systemd_notify_SOURCES = \
@@ -1239,7 +1240,8 @@ systemd_journalctl_SOURCES = \
systemd_journalctl_LDADD = \
libsystemd-basic.la \
- libsystemd-journal.la
+ libsystemd-journal.la \
+ libsystemd-id128.la
if HAVE_XZ
systemd_journalctl_SOURCES += \