summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFrederic Crozat <fcrozat@suse.com>2012-02-09 14:12:10 +0100
committerLennart Poettering <lennart@poettering.net>2012-02-09 21:57:58 +0100
commit4536f71691f6bbf40e1c82856850e0b7057b6e9d (patch)
tree489c0684cd2ebf749255df108c633eb78c1c8d9e /Makefile.am
parent02c4ef9c35e90ad562dc70fae25c81a8fd7f40f8 (diff)
kmod-setup: fix build with libkmod
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index fbf23587b..c5b819e4c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -546,7 +546,8 @@ libsystemd_core_la_CFLAGS = \
$(UDEV_CFLAGS) \
$(LIBWRAP_CFLAGS) \
$(PAM_CFLAGS) \
- $(AUDIT_CFLAGS)
+ $(AUDIT_CFLAGS) \
+ $(KMOD_CFLAGS)
libsystemd_core_la_LIBADD = \
libsystemd-basic.la \
@@ -555,7 +556,8 @@ libsystemd_core_la_LIBADD = \
$(LIBWRAP_LIBS) \
$(PAM_LIBS) \
$(AUDIT_LIBS) \
- $(CAP_LIBS)
+ $(CAP_LIBS) \
+ $(KMOD_LIBS)
# This is needed because automake is buggy in how it generates the
# rules for C programs, but not Vala programs. We therefore can't
@@ -728,12 +730,10 @@ systemd_SOURCES = \
systemd_CFLAGS = \
$(AM_CFLAGS) \
$(DBUS_CFLAGS) \
- $(UDEV_CFLAGS) \
- $(KMOD_CFLAGS)
+ $(UDEV_CFLAGS)
systemd_LDADD = \
- libsystemd-core.la \
- $(KMOD_LIBS)
+ libsystemd-core.la
test_engine_SOURCES = \
src/test-engine.c