summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2012-01-05 00:40:39 +0100
committerKay Sievers <kay.sievers@vrfy.org>2012-01-05 00:40:39 +0100
commitb8079ae19b41c9b61850c796dddc601b826850e0 (patch)
tree67c83327543bab2506dc8706b8095a7fe63e8621 /Makefile.am
parente6960940b6dc5ab81eb2fca4061c333e1795f38d (diff)
build-sys: rename 'rootdir' to 'rootprefix' like udev and kmod uses
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 09df759d0..21d833a4f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,12 +56,12 @@ usergeneratordir=$(pkglibexecdir)/user-generators
pkgincludedir=$(includedir)/systemd
# And these are the special ones for /
-rootdir=@rootdir@
-rootbindir=$(rootdir)/bin
-rootlibexecdir=$(rootdir)/lib/systemd
+rootprefix=@rootprefix@
+rootbindir=$(rootprefix)/bin
+rootlibexecdir=$(rootprefix)/lib/systemd
systemgeneratordir=$(rootlibexecdir)/system-generators
systemshutdowndir=$(rootlibexecdir)/system-shutdown
-systemunitdir=$(rootdir)/lib/systemd/system
+systemunitdir=$(rootprefix)/lib/systemd/system
CLEANFILES =
EXTRA_DIST =
@@ -89,6 +89,7 @@ AM_CPPFLAGS = \
-DSYSTEMCTL_BINARY_PATH=\"$(rootbindir)/systemctl\" \
-DSYSTEMD_TTY_ASK_PASSWORD_AGENT_BINARY_PATH=\"$(rootbindir)/systemd-tty-ask-password-agent\" \
-DSYSTEMD_STDIO_BRIDGE_BINARY_PATH=\"$(bindir)/systemd-stdio-bridge\" \
+ -DROOTPREFIX=\"$(rootprefix)\" \
-DRUNTIME_DIR=\"/run\" \
-DRANDOM_SEED=\"$(localstatedir)/lib/random-seed\" \
-DSYSTEMD_CRYPTSETUP_PATH=\"$(rootlibexecdir)/systemd-cryptsetup\" \
@@ -2396,7 +2397,7 @@ DISTCHECK_CONFIGURE_FLAGS = \
--with-dbusinterfacedir=$$dc_install_base/$(dbusinterfacedir) \
--with-udevrulesdir=$$dc_install_base/$(udevrulesdir) \
--with-pamlibdir=$$dc_install_base/$(pamlibdir) \
- --with-rootdir=$$dc_install_base/$(rootdir)
+ --with-rootprefix=$$dc_install_base/$(rootprefix)
upload: all distcheck
cp -v systemd-$(VERSION).tar.bz2 /home/lennart/git.fedora/systemd/