summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-01-21 00:51:37 +0100
committerLennart Poettering <lennart@poettering.net>2010-01-21 00:51:37 +0100
commit1ffba6fe82d65f2a87b53a21c7927bca8176038c (patch)
treea7e25b779085247caa54b1e9ee8424f98e4c44bb /Makefile
parent9ea024f6b5a9626ddabeb4c4d4385481b52d211e (diff)
fix job merging
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f4bbb2aef..5c6d798fb 100644
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@ LIBS=-lrt
COMMON=name.o util.o set.o hashmap.o strv.o job.o manager.o conf-parser.o load-fragment.o socket-util.o log.o
-all: systemd test-engine
+all: systemd test-engine test-job-type
systemd: main.o $(COMMON)
$(CC) $(CFLAGS) -o $@ $^ $(LIBS)
@@ -11,5 +11,8 @@ systemd: main.o $(COMMON)
test-engine: test-engine.o $(COMMON)
$(CC) $(CFLAGS) -o $@ $^ $(LIBS)
+test-job-type: test-job-type.o $(COMMON)
+ $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
+
clean:
rm -f *.o systemd test-engine