summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-02-02 22:22:51 +0100
committerLennart Poettering <lennart@poettering.net>2010-02-02 22:22:51 +0100
commit5630af71d72a2fa8142886ca2fb37e69a1906bca (patch)
tree8ea7cc0a6bca89ffbc5ce5f76aa79eed54f0c271 /Makefile
parentcc13a98b680087b24c1a319d10db98cd755a94d2 (diff)
client: add a very basic Vala command line tool
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 2f739ce2a..5a60eac9f 100644
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ COMMON= \
dbus-unit.o \
dbus-job.o
-all: systemd test-engine test-job-type systemd-logger
+all: systemd test-engine test-job-type systemd-logger systemctl
systemd: main.o $(COMMON)
$(CC) $(CFLAGS) -o $@ $^ $(LIBS)
@@ -43,5 +43,8 @@ test-engine: test-engine.o $(COMMON)
test-job-type: test-job-type.o $(COMMON)
$(CC) $(CFLAGS) -o $@ $^ $(LIBS)
+systemctl: systemctl.vala
+ valac --save-temps systemctl.vala --pkg=dbus-glib-1 --pkg=posix
+
clean:
- rm -f *.o systemd test-engine
+ rm -f *.o systemd test-engine systemctl