summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-01-20 05:03:52 +0100
committerLennart Poettering <lennart@poettering.net>2010-01-20 05:03:52 +0100
commit7fad411cb551c3c1cbe801a3991e7a6966e462b5 (patch)
treecd582a0482818ad1318e52eca0b305c537dcbc6d /Makefile
parent986b9910d3e0c94d3a9663f18e65157f4c4ee3ab (diff)
start implementing a test suite for the engine
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ae82e8ce8..cc55d4d14 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,15 @@
CFLAGS=-Wall -Wextra -O0 -g -pipe -D_GNU_SOURCE -fdiagnostics-show-option -Wno-unused-parameter
LIBS=-lrt
-systemd: main.o name.o util.o set.o hashmap.o strv.o job.o manager.o conf-parser.o load-fragment.o socket-util.c
+COMMON=name.o util.o set.o hashmap.o strv.o job.o manager.o conf-parser.o load-fragment.o socket-util.c
+
+all: systemd test-engine
+
+systemd: main.o $(COMMON)
+ $(CC) $(CFLAGS) -o $@ $^ $(LIBS)
+
+test-engine: test-engine.o $(COMMON)
$(CC) $(CFLAGS) -o $@ $^ $(LIBS)
clean:
- rm -f *.o systemd
+ rm -f *.o systemd test-engine