summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-01-26 19:12:56 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-01-26 23:56:34 -0500
commit10bc4cd469fc677892b07748ec85804ca120825f (patch)
tree662c8f72ce1bb03c0be25e6469e357fd183b254f /configure.ac
parent4a84f3e61434cdc52f91477d7fd937600159e4f1 (diff)
build-sys: unbundle unifont
We should prefer the unifont.hex file from the system, instead of our own. Upstream has made a few releases since our version was included, and we should follow upstream changes. But adding 2.6MB to our source repo every time upstream releases is not nice.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 12e4ab217..cf19681c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1142,16 +1142,25 @@ fi
AM_CONDITIONAL(ENABLE_EFI, [test "x$have_efi" = "xyes"])
# ------------------------------------------------------------------------------
+AC_ARG_WITH(unifont,
+ AS_HELP_STRING([--with-unifont=PATH],
+ [Path to unifont.hex]),
+ [UNIFONT="$withval"],
+ [UNIFONT="/usr/share/unifont/unifont.hex"])
+AC_SUBST(UNIFONT)
+
have_terminal=no
+have_unifont=no
AC_ARG_ENABLE(terminal, AS_HELP_STRING([--enable-terminal], [enable terminal support]))
if test "x$enable_terminal" = "xyes"; then
PKG_CHECK_MODULES([TERMINAL], [ libevdev >= 1.2 xkbcommon >= 0.5 libdrm >= 2.4], [have_terminal=yes])
- AS_IF([test "x$have_terminal" != xyes -a "x$enable_terminal" = xyes],
+ AC_CHECK_FILE($UNIFONT, [have_unifont=yes])
+ AS_IF([test "x$have_terminal" != xyes -o "x$have_unifont" != "xyes" -a "x$enable_terminal" = xyes],
[AC_MSG_ERROR([*** terminal support requested but required dependencies not available])],
- [test "x$have_terminal" = xyes],
+ [test "x$have_terminal" = xyes -a "x$have_unifont" = "xyes"],
[AC_DEFINE(ENABLE_TERMINAL, 1, [Define if terminal support is to be enabled])])
fi
-AM_CONDITIONAL(ENABLE_TERMINAL, [test "x$have_terminal" = "xyes"])
+AM_CONDITIONAL(ENABLE_TERMINAL, [test "x$have_terminal" = "xyes" -a "x$have_unifont" = "xyes"])
# ------------------------------------------------------------------------------
have_kdbus=no