summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-09-19 14:53:38 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-09-19 14:58:21 -0400
commit1864b0e39505cd44a98eee61c97916b86491c0b4 (patch)
treedde0763440c965ecf5e58b3c0f6e156ffa7b5a6d /configure.ac
parentcecf24e7f0f3385e7ced3e97d78cc9cc4012a650 (diff)
build-sys: don't build python modules after --without-python
The modules should build just fine, but AM_PATH_PYTHON sets pkgpyexecdir for us. Without that variable we don't know where to install modules. In addition libtool tries an empty rpath, breaking the build. Those issues could be fixed or worked around, but we probably don't have many people who want to avoid using python binary, but want to compile python modules. If such uses ever come up, this issue should be revisited.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d3f853f30..156cc96e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,9 +175,12 @@ AS_IF([test "x$PYTHON_BINARY" = "x"],
[PYTHON_BINARY=/usr/bin/python])])
AC_ARG_VAR(PYTHON_BINARY, [Python binary used to launch installed scripts])
+AS_IF([test "x$have_python" != "xyes" -a "x$enable_python_devel" = "xyes"],
+ [AC_MSG_ERROR([*** python-devel support requires --with-python])])
+
have_python_devel=no
AC_ARG_ENABLE(python_devel, AS_HELP_STRING([--disable-python-devel], [Do not build python modules]))
-AS_IF([test "x$enable_python_devel" != "xno"], [
+AS_IF([test "x$have_python" = "xyes" -a "x$enable_python_devel" != "xno"], [
PKG_CHECK_MODULES([PYTHON_DEVEL], [python-${PYTHON_VERSION}],
[have_python_devel=yes],
[PKG_CHECK_MODULES([PYTHON_DEVEL], [python],