summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2012-06-07 19:27:17 +0200
committerKay Sievers <kay@vrfy.org>2012-06-07 19:27:17 +0200
commit26cbf29c52a36b6ad9d1ccc16d8f7adccefeddca (patch)
treeffa074c6434d1cc9f5ede881d4006407c358ec77 /configure.ac
parented061a8dc2acd93c2eb569d2d983d5a77f7e5b77 (diff)
delete plymouth units; moved to plymouth
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 59892cb3d..70f3e9654 100644
--- a/configure.ac
+++ b/configure.ac
@@ -519,20 +519,17 @@ SYSTEM_SYSVINIT_PATH=/etc/init.d
SYSTEM_SYSVRCND_PATH=/etc/rc.d
M4_DEFINES=
-have_plymouth=no
case $with_distro in
fedora)
SYSTEM_SYSVINIT_PATH=/etc/rc.d/init.d
AC_DEFINE(TARGET_FEDORA, [], [Target is Fedora/RHEL])
M4_DEFINES=-DTARGET_FEDORA=1
- have_plymouth=yes
;;
opensuse|suse)
SYSTEM_SYSVRCND_PATH=/etc/init.d
AC_DEFINE(TARGET_SUSE, [], [Target is openSUSE/SLE])
M4_DEFINES=-DTARGET_SUSE=1
- have_plymouth=yes
;;
debian)
SYSTEM_SYSVRCND_PATH=/etc
@@ -565,19 +562,16 @@ case $with_distro in
SYSTEM_SYSVINIT_PATH=/etc/rc.d
AC_DEFINE(TARGET_FRUGALWARE, [], [Target is Frugalware])
M4_DEFINES=-DTARGET_FRUGALWARE=1
- have_plymouth=yes
;;
altlinux)
SYSTEM_SYSVINIT_PATH=/etc/rc.d/init.d
AC_DEFINE(TARGET_ALTLINUX, [], [Target is ALTLinux])
M4_DEFINES=-DTARGET_ALTLINUX=1
- have_plymouth=yes
;;
mandriva)
SYSTEM_SYSVINIT_PATH=/etc/rc.d/init.d
AC_DEFINE(TARGET_MANDRIVA, [], [Target is Mandriva])
M4_DEFINES=-DTARGET_MANDRIVA=1
- have_plymouth=yes
;;
meego)
SYSTEM_SYSVINIT_PATH=
@@ -594,7 +588,6 @@ case $with_distro in
SYSTEM_SYSVINIT_PATH=/etc/rc.d/init.d
AC_DEFINE(TARGET_MAGEIA, [], [Target is Mageia])
M4_DISTRO_FLAG=-DTARGET_MAGEIA=1
- have_plymouth=yes
;;
other)
;;
@@ -635,11 +628,6 @@ AC_ARG_WITH([tty-gid],
[AC_DEFINE_UNQUOTED(TTY_GID, [$withval], [GID of the 'tty' group])],
[])
-AC_ARG_ENABLE(plymouth, AS_HELP_STRING([--enable-plymouth], [enable plymouth support]))
-if test -n "$enable_plymouth"; then
- have_plymouth="$enable_plymouth"
-fi
-
AM_CONDITIONAL(TARGET_FEDORA, test x"$with_distro" = xfedora)
AM_CONDITIONAL(TARGET_SUSE, test x"$with_distro" = xsuse)
AM_CONDITIONAL(TARGET_DEBIAN, test x"$with_distro" = xdebian)
@@ -655,7 +643,6 @@ AM_CONDITIONAL(TARGET_MEEGO, test x"$with_distro" = xmeego)
AM_CONDITIONAL(TARGET_ANGSTROM, test x"$with_distro" = xangstrom)
AM_CONDITIONAL(TARGET_MAGEIA, test x"$with_distro" = xmageia)
-AM_CONDITIONAL(HAVE_PLYMOUTH, test "$have_plymouth" = "yes")
AM_CONDITIONAL(HAVE_SYSV_COMPAT, test "$SYSTEM_SYSV_COMPAT" = "yes")
AC_ARG_WITH([dbuspolicydir],
@@ -747,7 +734,6 @@ AC_MSG_RESULT([
timedated: ${have_timedated}
localed: ${have_localed}
coredump: ${have_coredump}
- plymouth: ${have_plymouth}
firmware path: ${FIRMWARE_PATH}
usb.ids: ${USB_DATABASE}
pci.ids: ${PCI_DATABASE}