summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2011-12-31 06:02:42 +0100
committerKay Sievers <kay.sievers@vrfy.org>2011-12-31 06:02:42 +0100
commit2a018e83ded29c9719b2478a65ee6245c829c0f5 (patch)
tree2ecc8fe2b67fe8c41aaf50e80fee72e87f8be702 /configure.ac
parentd85eed730107444505477106d2fdbd2767d4fd7a (diff)
build-sys: restructure logind parts in Makefile.am and add --disable-logind
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a2e9c7d65..ff9fe8890 100644
--- a/configure.ac
+++ b/configure.ac
@@ -316,6 +316,13 @@ if test "x$enable_binfmt" != "xno"; then
fi
AM_CONDITIONAL(ENABLE_BINFMT, [test "$have_binfmt" = "yes"])
+have_logind=no
+AC_ARG_ENABLE(logind, AS_HELP_STRING([--disable-logind], [disable login daemon]))
+if test "x$enable_logind" != "xno"; then
+ have_logind=yes
+fi
+AM_CONDITIONAL(ENABLE_LOGIND, [test "$have_logind" = "yes"])
+
have_hostnamed=no
AC_ARG_ENABLE(hostnamed, AS_HELP_STRING([--disable-hostnamed], [disable hostname daemon]))
if test "x$enable_hostnamed" != "xno"; then
@@ -607,6 +614,7 @@ AC_MSG_RESULT([
XZ: ${have_xz}
ACL: ${have_acl}
binfmt: ${have_binfmt}
+ logind: ${have_logind}
hostnamed: ${have_hostnamed}
timedated: ${have_timedated}
localed: ${have_localed}