summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Renner Berthing <systemd@esmil.dk>2014-09-24 17:25:00 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-09-26 07:48:35 -0400
commit37161c5148396448921841ae1026b281c7949652 (patch)
tree09dc44c0d051268fc31518dadbd4eb6255d85dbf /configure.ac
parent440c61c500ead1bdc6f987b8ba7c5e7f7a9c9f59 (diff)
make utmp/wtmp support configurable
This adds --disable-utmp option to configure. If it is used, all utmp-related functionality, including querying runlevel support, is removed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84644e163..e33c8f75a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -346,6 +346,16 @@ AS_IF([test "x$enable_dbus" != "xno"], [
AM_CONDITIONAL(HAVE_DBUS, [test "$have_dbus" = "yes"])
# ------------------------------------------------------------------------------
+have_utmp=yes
+AC_ARG_ENABLE([utmp], AS_HELP_STRING([--disable-utmp], [disable utmp/wtmp log handling]),
+ AS_CASE("x${enableval}",
+ [xyes], [have_utmp=yes],
+ [xno], [have_utmp=no],
+ AC_MSG_ERROR(bad value ${enableval} for --enable-utmp)))
+AS_IF([test "x$have_utmp" = "xyes"], [AC_DEFINE(HAVE_UTMP, 1, [Define if utmp/wtmp support is enabled])])
+AM_CONDITIONAL([HAVE_UTMP], [test "x$have_utmp" = "xyes"])
+
+# ------------------------------------------------------------------------------
have_compat_libs=no
AC_ARG_ENABLE([compat_libs], AS_HELP_STRING([--enable-compat-libs],[Enable creation of compatibility libraries]),
[case "${enableval}" in
@@ -1372,6 +1382,7 @@ AC_MSG_RESULT([
Split /usr: ${enable_split_usr}
SysV compatibility: ${SYSTEM_SYSV_COMPAT}
compatibility libraries: ${have_compat_libs}
+ utmp/wtmp support: ${have_utmp}
prefix: ${prefix}
rootprefix: ${with_rootprefix}