summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-10-14 04:31:49 +0200
committerLennart Poettering <lennart@poettering.net>2013-10-14 04:31:49 +0200
commit3990f247652c3bd41e4ea074e6302277eb9c7aa3 (patch)
treea374a06aa0c19ef135bf93f47cfc50c76b476c17 /configure.ac
parent0f4ba83c397e807939a4eb0b2cbd04ad4ab548cc (diff)
rfkill: add new rfkill tool to save/restore rfkill state across reboots
This works analogous to the existing backlight and random seed services
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00ee9bb92..6cda8f967 100644
--- a/configure.ac
+++ b/configure.ac
@@ -705,6 +705,14 @@ fi
AM_CONDITIONAL(ENABLE_BACKLIGHT, [test "$have_backlight" = "yes"])
# ------------------------------------------------------------------------------
+have_rfkill=no
+AC_ARG_ENABLE(rfkill, AS_HELP_STRING([--disable-rfkill], [disable rfkill tools]))
+if test "x$enable_rfkill" != "xno"; then
+ have_rfkill=yes
+fi
+AM_CONDITIONAL(ENABLE_RFKILL, [test "$have_rfkill" = "yes"])
+
+# ------------------------------------------------------------------------------
have_logind=no
AC_ARG_ENABLE(logind, AS_HELP_STRING([--disable-logind], [disable login daemon]))
if test "x$enable_logind" != "xno"; then
@@ -1042,6 +1050,7 @@ AC_MSG_RESULT([
tmpfiles: ${have_tmpfiles}
randomseed: ${have_randomseed}
backlight: ${have_backlight}
+ rfkill: ${have_rfkill}
logind: ${have_logind}
machined: ${have_machined}
hostnamed: ${have_hostnamed}