summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUmut Tezduyar <umut@tezduyar.com>2013-06-02 10:54:44 +0200
committerTom Gundersen <teg@jklm.no>2013-06-02 11:12:14 +0200
commit6351163bf3e519cc07adb2732d12450741f5a0d3 (patch)
treea03e7f76c0c1e32238fb7c9f6f0c232d24b973af /configure.ac
parentfe1abefcd3bf1718dde3b5b835db56142c9f7082 (diff)
build-sys: option to disable tmpfiles
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c24b4a818..d266601ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -617,6 +617,14 @@ fi
AM_CONDITIONAL(ENABLE_QUOTACHECK, [test "$have_quotacheck" = "yes"])
# ------------------------------------------------------------------------------
+have_tmpfiles=no
+AC_ARG_ENABLE(tmpfiles, AS_HELP_STRING([--disable-tmpfiles], [disable tmpfiles support]))
+if test "x$enable_tmpfiles" != "xno"; then
+ have_tmpfiles=yes
+fi
+AM_CONDITIONAL(ENABLE_TMPFILES, [test "$have_tmpfiles" = "yes"])
+
+# ------------------------------------------------------------------------------
have_randomseed=no
AC_ARG_ENABLE(randomseed, AS_HELP_STRING([--disable-randomseed], [disable randomseed tools]))
if test "x$enable_randomseed" != "xno"; then
@@ -954,6 +962,7 @@ AC_MSG_RESULT([
readahead: ${have_readahead}
bootchart: ${have_bootchart}
quotacheck: ${have_quotacheck}
+ tmpfiles: ${have_tmpfiles}
randomseed: ${have_randomseed}
logind: ${have_logind}
hostnamed: ${have_hostnamed}