summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-14 22:10:44 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-14 22:10:44 -0400
commit6581f00f7eabdaccf587a4b6af60ed4696dd2791 (patch)
tree8b332db1248b310d507370666a4242a7e56cc834 /configure.ac
parent39887731d4a36292674f92effa30e5941419c201 (diff)
build-sys: properly report missing gtk-doc
This brings the check for ENABLE_GTK_DOC in line with HAVE_INTROSPECTION and other similar checks. Only the status line that is printed with uninstalled gtk-doc is changed. https://bugs.freedesktop.org/show_bug.cgi?id=63108
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e1278e850..781ea5a85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,9 +72,10 @@ AC_PATH_PROG([SETCAP], [setcap], [/usr/sbin/setcap])
AC_PATH_PROG([KILL], [kill], [/usr/bin/kill])
# gtkdocize greps for '^GTK_DOC_CHECK', so it needs to be on its own line
-m4_ifdef([GTK_DOC_CHECK], [
-GTK_DOC_CHECK([1.18],[--flavour no-tmpl])
-], [AM_CONDITIONAL([ENABLE_GTK_DOC], [false])])
+m4_ifdef([GTK_DOC_CHECK],
+ [GTK_DOC_CHECK([1.18],[--flavour no-tmpl])],
+ [AM_CONDITIONAL([ENABLE_GTK_DOC], [false])
+ enable_gtk_doc=no])
AS_IF([test "x$enable_gtk_doc" = "xyes" -a "x$XSLTPROC" = x], [
AC_MSG_ERROR([*** GTK doc requested but xsltproc not found])