summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2015-01-27 17:24:11 +0100
committerLennart Poettering <lennart@poettering.net>2015-01-27 17:58:57 +0100
commit831f18cbf3f250207fcde15ea736639898317d77 (patch)
treead37898d96cd1e93437fe5095db369ade3532b1a /configure.ac
parent0ef403877a2257199ef22af5e217831d03eae8af (diff)
build-sys: make bzip2 really optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cf19681c8..d576e0409 100644
--- a/configure.ac
+++ b/configure.ac
@@ -580,11 +580,13 @@ AM_CONDITIONAL(HAVE_ZLIB, [test "$have_zlib" = "yes"])
# ------------------------------------------------------------------------------
have_bzip2=no
-AC_ARG_ENABLE(bzip2, AS_HELP_STRING([--enable-bzip2], [Enable optional BZIP2 support]))
+AC_ARG_ENABLE(bzip2, AS_HELP_STRING([--enable-bzip2], [Disable optional BZIP2 support]))
AS_IF([test "x$enable_bzip2" != "xno"], [
AC_CHECK_HEADERS(bzlib.h,
- [AC_DEFINE(HAVE_BZIP2, 1, [Define in BZIP2 is available]) have_bzip2=yes],
- [AC_MSG_ERROR([*** BZIP2 support requested but headers not found])])
+ [AC_DEFINE(HAVE_BZIP2, 1, [Define in BZIP2 is available])
+ have_bzip2=yes],
+ [AS_IF([test "x$have_bzip2" = xyes], [AC_MSG_ERROR([*** BZIP2 support requested but headers not found])])
+ ])
])
AM_CONDITIONAL(HAVE_BZIP2, [test "$have_bzip2" = "yes"])