summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2015-01-21 13:43:55 +0100
committerLennart Poettering <lennart@poettering.net>2015-01-21 13:44:29 +0100
commit8af3cf74df03f7528f9e2605ec7896a5daf0f711 (patch)
treeac5a1c8c4d1997a45b5967a796373bb877bd6a54 /configure.ac
parentccf23ad5faf228d450d263d7291156a948b61af2 (diff)
import: support downloading bzip2-encoded images
This way, we can import CoreOS images unmodified.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d82cfe890..e0320057f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -577,6 +577,16 @@ fi
AM_CONDITIONAL(HAVE_ZLIB, [test "$have_zlib" = "yes"])
# ------------------------------------------------------------------------------
+have_bzip2=no
+AC_ARG_ENABLE(bzip2, AS_HELP_STRING([--enable-bzip2], [Enable optional BZIP2 support]))
+AS_IF([test "x$enable_bzip2" != "xno"], [
+ AC_CHECK_HEADERS(bzlib.h,
+ [AC_DEFINE(HAVE_BZIP2, 1, [Define in BZIP2 is available]) have_bzip2=yes],
+ [AC_MSG_ERROR([*** BZIP2 support requested but headers not found])])
+])
+AM_CONDITIONAL(HAVE_BZIP2, [test "$have_bzip2" = "yes"])
+
+# ------------------------------------------------------------------------------
have_lz4=no
AC_ARG_ENABLE(lz4, AS_HELP_STRING([--enable-lz4], [Enable optional LZ4 support]))
AS_IF([test "x$enable_lz4" = "xyes"], [
@@ -1426,6 +1436,7 @@ AC_MSG_RESULT([
ZLIB: ${have_zlib}
XZ: ${have_xz}
LZ4: ${have_lz4}
+ BZIP2: ${have_bzip2}
ACL: ${have_acl}
GCRYPT: ${have_gcrypt}
QRENCODE: ${have_qrencode}