summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-12-22 19:42:27 +0100
committerLennart Poettering <lennart@poettering.net>2014-12-23 03:25:36 +0100
commit91f4347ef7bde17418b365ed3a97a752fe65bd50 (patch)
tree928b29fdaa4364626d2875b226daa025416fd4fa /configure.ac
parent9bae67d49b861b1f142f1a1e27753fe08e63ade7 (diff)
import: rename 'poll-dck' to 'pull-dkr'
I figure "pull-dck" is not a good name, given that one could certainly read the verb in a way that might be funny for 16year-olds. ;-) Also, don't hardcode the index URL to use, make it runtime and configure time configurable instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9296c25db..0e7216638 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1316,6 +1316,14 @@ AC_ARG_ENABLE([split-usr],
enable_split_usr=no
])])
+AC_ARG_WITH([dkr-index-url],
+ [AS_HELP_STRING([--dkr-index-url=URL], [Specify the default index URL to use for image downloads])],
+ [DEFAULT_DKR_INDEX_URL="\"$withval\""],
+ [DEFAULT_DKR_INDEX_URL="NULL"])
+
+AC_DEFINE_UNQUOTED(DEFAULT_DKR_INDEX_URL, [$DEFAULT_DKR_INDEX_URL], [Default index URL to use for image downloads])
+AC_SUBST(DEFAULT_DKR_INDEX_URL)
+
AS_IF([test "x${enable_split_usr}" = "xyes"], [
AC_DEFINE(HAVE_SPLIT_USR, 1, [Define if /bin, /sbin aren't symlinks into /usr])
])
@@ -1478,6 +1486,7 @@ AC_MSG_RESULT([
Maximum System UID: ${SYSTEM_UID_MAX}
Maximum System GID: ${SYSTEM_GID_MAX}
Certificate root: ${CERTIFICATEROOT}
+ Default dkr Index ${DEFAULT_DKR_INDEX_URL}
CFLAGS: ${OUR_CFLAGS} ${CFLAGS}
CPPFLAGS: ${OUR_CPPFLAGS} ${CPPFLAGS}