summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFilipe Brandenburger <filbranden@google.com>2014-12-23 10:59:14 -0800
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-12-25 10:55:42 -0500
commit977db91c29083478c6fb7c7bf033e14c567df5d5 (patch)
tree5f3a9527d1f73f43228274d1232d5abe1c59f63e /configure.ac
parentfa66b606b1a79530bc0d7f70ff30955232e40694 (diff)
build-sys: do not use pkgconfig dbus-1.pc to find dbus directories
Do not use the dbus-1.pc pkgconfig settings to determine dbus directories. Use directories relative to ${sysconfdir} and ${datadir} instead. This approach was suggested by Simon McVittie in: http://lists.freedesktop.org/archives/systemd-devel/2014-October/024388.html Tested by building and installing systemd without the dbus-devel installed. Without this patch, the dbus files and directories end up in the root of the filesystem. With this patch, they end up in the same locations as previously (assuming default ${sysconfdir} and ${datadir}) whether dbus-devel is present or not. Also made sure that `make check` works without dbus-devel installed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0e7216638..f20c0e78a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1258,22 +1258,22 @@ AC_SUBST(TTY_GID)
AC_ARG_WITH([dbuspolicydir],
AS_HELP_STRING([--with-dbuspolicydir=DIR], [D-Bus policy directory]),
[],
- [with_dbuspolicydir=$($PKG_CONFIG --variable=sysconfdir dbus-1)/dbus-1/system.d])
+ [with_dbuspolicydir=${sysconfdir}/dbus-1/system.d])
AC_ARG_WITH([dbussessionservicedir],
AS_HELP_STRING([--with-dbussessionservicedir=DIR], [D-Bus session service directory]),
[],
- [with_dbussessionservicedir=$($PKG_CONFIG --variable=session_bus_services_dir dbus-1)])
+ [with_dbussessionservicedir=${datadir}/dbus-1/services])
AC_ARG_WITH([dbussystemservicedir],
AS_HELP_STRING([--with-dbussystemservicedir=DIR], [D-Bus system service directory]),
[],
- [with_dbussystemservicedir=$(readlink -m $($PKG_CONFIG --variable=session_bus_services_dir dbus-1)/../system-services)])
+ [with_dbussystemservicedir=${datadir}/dbus-1/system-services])
AC_ARG_WITH([dbusinterfacedir],
AS_HELP_STRING([--with-dbusinterfacedir=DIR], [D-Bus interface directory]),
[],
- [with_dbusinterfacedir=$(readlink -m $($PKG_CONFIG --variable=session_bus_services_dir dbus-1)/../interfaces)])
+ [with_dbusinterfacedir=${datadir}/dbus-1/interfaces])
AC_ARG_WITH([bashcompletiondir],
AS_HELP_STRING([--with-bashcompletiondir=DIR], [Bash completions directory]),