summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2015-01-16 20:07:25 +0100
committerLennart Poettering <lennart@poettering.net>2015-01-16 20:09:33 +0100
commitedce2aed3aa93b84f7b4c70412bdb665da2977b0 (patch)
tree6953215eb2e65cc79c417fb5d1d6923ef5a2a9a0 /configure.ac
parent49bb233bb734536b9617d838f09a7bf9b8336003 (diff)
import: support importing qcow2 images
With this change the import tool will now unpack qcow2 images into normal raw disk images, suitable for usage with nspawn. This allows has the benefit of also allowing importing Ubuntu Cloud images for usage with nspawn.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5057f8e99..6d510df33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -564,6 +564,18 @@ fi
AM_CONDITIONAL(HAVE_XZ, [test "$have_xz" = "yes"])
# ------------------------------------------------------------------------------
+have_zlib=no
+AC_ARG_ENABLE(zlib, AS_HELP_STRING([--disable-zlib], [Disable optional ZLIB support]))
+if test "x$enable_zlib" != "xno"; then
+ PKG_CHECK_MODULES(ZLIB, [ zlib ],
+ [AC_DEFINE(HAVE_ZLIB, 1, [Define if ZLIB is available]) have_zlib=yes])
+ if test "x$have_zlib" = xno -a "x$enable_zlib" = xyes; then
+ AC_MSG_ERROR([*** ZLIB support requested but libraries not found])
+ fi
+fi
+AM_CONDITIONAL(HAVE_ZLIB, [test "$have_zlib" = "yes"])
+
+# ------------------------------------------------------------------------------
have_lz4=no
AC_ARG_ENABLE(lz4, AS_HELP_STRING([--enable-lz4], [Enable optional LZ4 support]))
AS_IF([test "x$enable_lz4" = "xyes"], [
@@ -1410,6 +1422,7 @@ AC_MSG_RESULT([
SELinux: ${have_selinux}
SECCOMP: ${have_seccomp}
SMACK: ${have_smack}
+ ZLIB: ${have_zlib}
XZ: ${have_xz}
LZ4: ${have_lz4}
ACL: ${have_acl}