summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShawn Landden <shawnlandden@gmail.com>2013-07-21 20:57:35 -0700
committerKay Sievers <kay@vrfy.org>2013-07-30 02:35:36 +0200
commitfba1ea06bb5b653e9eb0cc1b6004af8da273a4ab (patch)
treee56ed681f4e9f21dda468a4cc97b62197809535b /configure.ac
parentce8aba568156f2b9d0d3b023e960cda3d9d7db81 (diff)
build: do not link everything with -lrt (and therefore -pthread)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e8c573ab..76aa2a920 100644
--- a/configure.ac
+++ b/configure.ac
@@ -190,7 +190,6 @@ AM_CONDITIONAL([HAVE_PYTHON_DEVEL], [test "$have_python_devel" = "yes"])
# ------------------------------------------------------------------------------
-AC_SEARCH_LIBS([mq_open], [rt], [], [AC_MSG_ERROR([*** POSIX RT library not found])])
AC_SEARCH_LIBS([dlsym], [dl], [], [AC_MSG_ERROR([*** Dynamic linking loader library not found])])
save_LIBS="$LIBS"
@@ -198,6 +197,9 @@ LIBS=
AC_SEARCH_LIBS([cap_init], [cap], [], [AC_MSG_ERROR([*** POSIX caps library not found])])
AC_CHECK_HEADERS([sys/capability.h], [], [AC_MSG_ERROR([*** POSIX caps headers not found])])
CAP_LIBS="$LIBS"
+AC_SEARCH_LIBS([mq_open], [rt], [], [AC_MSG_ERROR([*** POSIX RT library not found])])
+RT_LIBS="$LIBS"
+AC_SUBST(RT_LIBS)
LIBS="$save_LIBS"
AC_SUBST(CAP_LIBS)