summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2013-10-21 18:28:23 +0200
committerKay Sievers <kay@vrfy.org>2013-10-21 18:29:53 +0200
commit03a170c03cd4a09721369ece48affb70d66c6b90 (patch)
treebb5113e355855addb74dd42d318f15dd5d95a6b1 /configure.ac
parentdf28bc0836ad6a79cb537ad0b463819738088f3e (diff)
build-sys: disable _FORTIFY_SOURCE for -Og builds for now
Older gcc versions throw things like: In file included from /usr/include/fcntl.h:302:0, from ../src/core/execute.c:25: In function 'open', inlined from 'open_null_as' at ../src/core/execute.c:196:12: /usr/include/bits/fcntl2.h:50:24: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments __open_missing_mode ();
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b09f333a0..7e41d577b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,7 +157,7 @@ CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
--param=ssp-buffer-size=4])
AC_SUBST([OUR_CFLAGS], "$with_cflags $address_sanitizer_cflags")
-AS_CASE([$CFLAGS], [*-O[[12345g\ ]]*],
+AS_CASE([$CFLAGS], [*-O[[12345\ ]]*],
[CC_CHECK_FLAGS_APPEND([with_cppflags], [CPPFLAGS], [\
-Wp,-D_FORTIFY_SOURCE=2])],
[AC_MSG_RESULT([skipping -D_FORTIFY_SOURCE, optimization not enabled])])