summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@gmail.com>2015-02-24 15:59:06 +0100
committerDavid Herrmann <dh.herrmann@gmail.com>2015-02-24 16:02:32 +0100
commit0a98d66159e474915afd6597d3aa444a698fdd2d (patch)
tree7680900b9432abee4407f583b6362d4b86dff62e /configure.ac
parenta804d849b3c2199bc25d1d4e65fc119fa4d7d0e2 (diff)
build: add -Wno-format-signedness
gcc5 introduced this option (gcc4 silently ignores it, which is fine). Given that gcc5 thinks 'unsigned char'/'unsigned short' is promoted to 'int' for var-args, stuff like this spits out warnings: uint8_t x; printf("%" PRIu8", x); gcc5 promots 'x' to 'int', instead of 'unsigned int' and thus gets a signedness-warnings as it expects an 'unsigned int'. glibc states otherwise: unsigneds are always promoted to 'unsigned int'. Until gcc and glibc figure this out, lets just ignore that warning (which is totally useless in its current form).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a2235bcf..22a6f1781 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,7 @@ CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
-Wno-unused-parameter \
-Wno-missing-field-initializers \
-Wno-unused-result \
+ -Wno-format-signedness \
-Werror=overflow \
-Wdate-time \
-Wnested-externs \