summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2014-01-05 11:57:05 -0500
committerDave Reisner <dreisner@archlinux.org>2014-01-05 11:57:05 -0500
commit146ccaafd5c9d4f2798240b049f595f70f45f77b (patch)
tree75addc6c5268801ef2d6a47297eb0ada7f31c08f /configure.ac
parent2047a15a17d9773cc87569b4176af72830a086eb (diff)
configure: use POSIX conformant syntax for test
In shells like bash, == and = are equivalent in test contexts. In POSIX compliant shells, == isn't a valid operator.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d8a9356ad..714062724 100644
--- a/configure.ac
+++ b/configure.ac
@@ -816,7 +816,7 @@ AM_CONDITIONAL(ENABLE_MULTI_SEAT_X, [test "$have_multi_seat_x" = "yes"])
# ------------------------------------------------------------------------------
have_kdbus=no
AC_ARG_ENABLE(kdbus, AS_HELP_STRING([--enable-kdbus], [do connect to kdbus by default]))
-if test "x$enable_kdbus" == "xyes"; then
+if test "x$enable_kdbus" = "xyes"; then
AC_DEFINE(ENABLE_KDBUS, 1, [Define if kdbus support is to be enabled])
have_kdbus=yes
M4_DEFINES="$M4_DEFINES -DENABLE_KDBUS"