summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Mack <zonque@gmail.com>2013-11-30 00:45:53 +0100
committerDaniel Mack <zonque@gmail.com>2013-12-16 22:34:48 +0100
commit294c866023d05162880b056fea5242d25cd9e865 (patch)
treefa1f750dab2eabf96cb891e64fe690f4f8f3daf6 /configure.ac
parent16ac401407959cbc62312e61c2dd76dbc3a0793b (diff)
Add bus-driverd
systemd-bus-driverd is a small daemon that connects to kdbus and implements the org.freedesktop.DBus interface. IOW, it provides the bus functions traditionally taken care for by dbus-daemon. Calls are proxied to kdbus, either via libsystemd-bus (were applicable) or with the open-coded use of ioctl(). Note that the implementation is not yet finished as the functions to add and remove matches and to start services by name are still missing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9a32d9c8b..8d16bd459 100644
--- a/configure.ac
+++ b/configure.ac
@@ -751,6 +751,14 @@ fi
AM_CONDITIONAL(ENABLE_TIMEDATED, [test "$have_timedated" = "yes"])
# ------------------------------------------------------------------------------
+have_bus_driverd=no
+AC_ARG_ENABLE(bus_driverd, AS_HELP_STRING([--disable-bus-driverd], [disable systemd bus-driver daemon]))
+if test "x$enable_bus_driverd" != "xno"; then
+ have_bus_driverd=yes
+fi
+AM_CONDITIONAL(ENABLE_BUS_DRIVERD, [test "$have_bus_driverd" = "yes"])
+
+# ------------------------------------------------------------------------------
have_localed=no
AC_ARG_ENABLE(localed, AS_HELP_STRING([--disable-localed], [disable locale daemon]))
if test "x$enable_localed" != "xno"; then