summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-02-12 02:58:41 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-02-12 03:04:57 -0500
commit32dcef3ab1eb91ee469c3246ef859578dccd8a45 (patch)
treee8466f7e96b0db6e0913f003c4fbfa4e74a0e768 /configure.ac
parentfeef0842cfa8abe8b76c16e026217bad7e90f283 (diff)
build-sys: make lxml required when generating indices
Since the manpage indices generated without lxml would be missing some parts, it doesn't make sense to keep lxml optional anymore.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d92f1fe01..59650a256 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,9 +188,11 @@ have_python=no
AC_ARG_WITH([python],
[AS_HELP_STRING([--without-python], [Disable building the man page index and systemd-python (default: test)])])
+have_lxml=no
AS_IF([test "x$with_python" != "xno"], [
AM_PATH_PYTHON(,, [:])
- AS_IF([test "$PYTHON" != :], [have_python=yes])
+ AS_IF(["$PYTHON" -c 'import lxml' 2>/dev/null], [have_lxml=yes], [have_lxml=no])
+ AS_IF([test "$PYTHON" != : -a $have_lxml = yes], [have_python=yes])
])
AM_CONDITIONAL([HAVE_PYTHON], [test "x$have_python" = "xyes"])
AS_IF([test "x$PYTHON_BINARY" = "x"],