summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-01-21 20:38:49 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-01-25 18:10:08 -0500
commit39c4ead2323b45bbe9866e0f97fd8dcfb8a0bede (patch)
tree53a41da4de1b0fd959b7352ae474dcccf5fc535c /configure.ac
parent7a821bfec1bffff043a5bcd82f9cba8927b4b4cb (diff)
build-sys: default to gold linker
gold doesn't exhibit the problems with linking of compatibility libraries. It is also slightly faster: make clean && make -j5 bfd gold real 34.885s 33.707s user 34.486s 32.189s sys 9.929s 10.845s real 35.128s 33.508s user 34.660s 31.858s sys 10.798s 10.341s real 35.405s 33.748s user 34.765s 32.384s sys 11.635s 10.998s real 35.250s 33.795s user 34.704s 32.253s sys 11.220s 11.469s touch src/libsystemd/sd-bus.c && make -j5 bfd gold real 10.224s 9.030s user 11.664s 9.877s sys 3.431s 2.878s real 10.021s 9.165s user 11.526s 9.990s sys 3.061s 3.015s real 10.233s 8.961s user 11.657s 9.973s sys 3.467s 2.202s real 10.160s 9.086s user 11.637s 9.950s sys 3.188s 2.859s
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 939ba6dcf..6c1ba7c23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,7 +175,8 @@ CC_CHECK_FLAGS_APPEND([with_ldflags], [LDFLAGS], [\
-Wl,--no-undefined \
-Wl,--gc-sections \
-Wl,-z,relro \
- -Wl,-z,now])
+ -Wl,-z,now \
+ -Wl,-fuse-ld=gold])
AC_SUBST([OUR_LDFLAGS], "$with_ldflags $address_sanitizer_ldflags")
AC_CHECK_SIZEOF(pid_t)