summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Schurig <holgerschurig@gmail.com>2014-02-20 14:39:13 +0100
committerLennart Poettering <lennart@poettering.net>2014-02-21 03:06:29 +0100
commit3b794314149e40afaf3c456285e1e529747b6560 (patch)
tree90c1b0327fc514c8a56a41292772a427ddf7aea4 /configure.ac
parentd9d93745cd2efcdfca8f82d798e61e0ee70cef5c (diff)
build-sys: Add setns() functions if not in the C library.
Debian Stable is still using glibc 2.13, which doesn't provide the setns(). So we detect this and provide a tiny wrapper that issues the setns syscall towards the kernel.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 05ee098d2..18df6d86e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,10 +241,11 @@ LIBS="$save_LIBS"
AC_CHECK_FUNCS([fanotify_init fanotify_mark])
AC_CHECK_FUNCS([__secure_getenv secure_getenv])
-AC_CHECK_DECLS([gettid, pivot_root, name_to_handle_at], [], [], [[#include <sys/types.h>
+AC_CHECK_DECLS([gettid, pivot_root, name_to_handle_at, setns], [], [], [[#include <sys/types.h>
#include <unistd.h>
#include <sys/mount.h>
-#include <fcntl.h>]])
+#include <fcntl.h>
+#include <sched.h>]])
# This makes sure pkg.m4 is available.
m4_pattern_forbid([^_?PKG_[A-Z_]+$],[*** pkg.m4 missing, please install pkg-config])