summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-01-19 08:50:02 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-01-25 18:10:08 -0500
commit53e856e16ac37fe30b8bb59153ff69aad0fa9c27 (patch)
tree0bbd3b2a038de5cc66249fdf892f38001d4f0586 /configure.ac
parent242465b5bfcc2ea1b1d704907e7dd5f1c15d4404 (diff)
build-sys: create "compatibility libraries" section
Compat stuff is moved to src/compat-libs/. Warnings are issued when programs are linked with the deprecated library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c1ba7c23..d92f1fe01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,6 +259,17 @@ AS_IF([test "x$enable_dbus" != "xno"], [
AM_CONDITIONAL(HAVE_DBUS, [test "$have_dbus" = "yes"])
# ------------------------------------------------------------------------------
+have_compat_libs=no
+AC_ARG_ENABLE([compat_libs], AS_HELP_STRING([--enable-compat-libs],[Enable creation of compatibility libraries]),
+ [case "${enableval}" in
+ yes) have_compat_libs=yes ;;
+ no) have_compat_libs=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-compat-libs) ;;
+ esac],
+ [have_compat_libs=no])
+AM_CONDITIONAL([ENABLE_COMPAT_LIBS], [test "$have_compat_libs" = "yes"])
+
+# ------------------------------------------------------------------------------
have_coverage=no
AC_ARG_ENABLE(coverage, AS_HELP_STRING([--enable-coverage], [enable test coverage]))
if test "x$enable_coverage" = "xyes" ; then
@@ -1117,6 +1128,7 @@ AC_MSG_RESULT([
test coverage: ${have_coverage}
Split /usr: ${enable_split_usr}
SysV compatibility: ${SYSTEM_SYSV_COMPAT}
+ compatibility libraries: ${have_compat_libs}
prefix: ${prefix}
rootprefix: ${with_rootprefix}