summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorŁukasz Stelmach <l.stelmach@samsung.com>2014-11-28 15:59:59 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-11-30 23:50:19 -0500
commit5a16bc264c32237e38a844d55e7a1820a31b8440 (patch)
tree0f259cac8dcc873dff16ea25f8c6e9f7b7dc6889 /configure.ac
parentf4e9cdbc6259237b2cb779a16e7c1aca0fd44e58 (diff)
build-sys: configure the list of system users, files and directories
Choose which system users defined in sysusers.d/systemd.conf and files or directories in tmpfiles.d/systemd.conf, should be provided depending on comile-time configuration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 928ac2e99..356a3c3d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -984,6 +984,7 @@ have_timesyncd=no
AC_ARG_ENABLE(timesyncd, AS_HELP_STRING([--disable-timesyncd], [disable timesync daemon]))
if test "x$enable_timesyncd" != "xno"; then
have_timesyncd=yes
+ M4_DEFINES="$M4_DEFINES -DENABLE_TIMESYNCD"
fi
AM_CONDITIONAL(ENABLE_TIMESYNCD, [test "$have_timesyncd" = "yes"])
@@ -1073,6 +1074,7 @@ AC_ARG_ENABLE(networkd, AS_HELP_STRING([--disable-networkd], [disable networkd])
AS_IF([test "x$enable_networkd" != "xno"], [
AC_DEFINE(ENABLE_NETWORKD, 1, [Define if networkd support is to be enabled])
have_networkd=yes
+ M4_DEFINES="$M4_DEFINES -DENABLE_NETWORKD"
])
AM_CONDITIONAL(ENABLE_NETWORKD, [test "x$have_networkd" = "xyes"])