summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2012-11-28 12:45:31 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-03-17 01:55:48 -0400
commit6031319956b4b1d13799373bfda3e8690f6fa874 (patch)
tree190b3bbbf795b7cf7a3da8ddb3bd6f26560cae9f /configure.ac
parente5ebe12b770bbb7bf73177517c339dc3601a5efc (diff)
build-sys: add check on gnutls
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae5a6b5a3..9e0739a6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -709,6 +709,18 @@ fi
AM_CONDITIONAL(HAVE_MICROHTTPD, [test "$have_microhttpd" = "yes"])
# ------------------------------------------------------------------------------
+have_gnutls=no
+AC_ARG_ENABLE(gnutls, AS_HELP_STRING([--disable-gnutls], [disable gnutls support]))
+if test "x$enable_gnutls" != "xno"; then
+ PKG_CHECK_MODULES(GNUTLS, [gnutls],
+ [AC_DEFINE(HAVE_GNUTLS, 1, [Define if gnutls is available]) have_gnutls=yes], have_gnutls=no)
+ if test "x$have_gnutls" = xno -a "x$enable_gnutls" = xyes; then
+ AC_MSG_ERROR([*** gnutls support requested but libraries not found])
+ fi
+fi
+AM_CONDITIONAL(HAVE_GNUTLS, [test "$have_gnutls" = "yes"])
+
+# ------------------------------------------------------------------------------
have_binfmt=no
AC_ARG_ENABLE(binfmt, AS_HELP_STRING([--disable-binfmt], [disable binfmt tool]))
if test "x$enable_binfmt" != "xno"; then
@@ -1132,6 +1144,7 @@ AC_MSG_RESULT([
QRENCODE: ${have_qrencode}
MICROHTTPD: ${have_microhttpd}
CHKCONFIG: ${have_chkconfig}
+ GNUTLS: ${have_gnutls}
binfmt: ${have_binfmt}
vconsole: ${have_vconsole}
readahead: ${have_readahead}