summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-02-17 17:49:09 +0100
committerLennart Poettering <lennart@poettering.net>2014-02-17 17:49:09 +0100
commit6a6751fe24bf456cf5c1efad785a4d11e78b42d0 (patch)
treeca155515abb5149ce5df1dc5c70417a1c9dde115 /configure.ac
parent5f8640fb628cb034981e02d741fd9ddf26fdf38d (diff)
core: warn when unit files with unsupported options are parsed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 48d63e879..9e5a68170 100644
--- a/configure.ac
+++ b/configure.ac
@@ -375,7 +375,10 @@ have_selinux=no
AC_ARG_ENABLE(selinux, AS_HELP_STRING([--disable-selinux], [Disable optional SELINUX support]))
if test "x$enable_selinux" != "xno"; then
PKG_CHECK_MODULES([SELINUX], [libselinux >= 2.1.9],
- [AC_DEFINE(HAVE_SELINUX, 1, [Define if SELinux is available]) have_selinux=yes], have_selinux=no)
+ [AC_DEFINE(HAVE_SELINUX, 1, [Define if SELinux is available])
+ have_selinux=yes
+ M4_DEFINES="$M4_DEFINES -DHAVE_SELINUX"],
+ [have_selinux=no])
if test "x$have_selinux" = xno -a "x$enable_selinux" = xyes; then
AC_MSG_ERROR([*** SELinux support requested but libraries not found])
fi
@@ -428,6 +431,7 @@ if test "x${have_tcpwrap}" != xno ; then
fi
have_tcpwrap=no
else
+ M4_DEFINES="$M4_DEFINES -DHAVE_LIBWRAP"
have_tcpwrap=yes
fi
else
@@ -464,6 +468,7 @@ if test "x${have_pam}" != xno ; then
if test "x$have_pam" = xyes ; then
PAM_LIBS="-lpam -lpam_misc"
AC_DEFINE(HAVE_PAM, 1, [PAM available])
+ M4_DEFINES="$M4_DEFINES -DHAVE_PAM"
else
have_pam=no
fi
@@ -566,6 +571,7 @@ if test "x${have_xattr}" = xno; then
fi
else
if test "x${have_smack}" = xauto; then
+ M4_DEFINES="$M4_DEFINES -DHAVE_SMACK"
have_smack=yes
fi
fi