summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-20 18:14:22 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-20 18:44:40 -0400
commit747cf8cdf61cdad068c727e42eac699f2505ae77 (patch)
tree117fe32e7c180615dc5425a98bb4e998e5f8b72c /configure.ac
parent65adc982db09a144d61551d5acc9340366cc46e2 (diff)
build-sys: fail if python support requested but not found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1aff72d3b..a87a02656 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,6 +224,13 @@ AS_IF([test "x$with_python" != "xno"], [
[AC_MSG_WARN([*** python support requires python-lxml module installed])])
])
])
+AS_IF([test "$have_python" != "yes"], [
+ AS_IF([test "$with_python" = "yes"],
+ [AC_MSG_ERROR([*** python support requested but python support not found])])
+ AS_IF([test "$with_python" != "no"],
+ [AC_MSG_WARN([*** python support not found, some documentation cannot be built])])
+])
+
AM_CONDITIONAL([HAVE_PYTHON], [test "x$have_python" = "xyes"])
AS_IF([test "x$PYTHON_BINARY" = "x"],
[AS_IF([test "x$have_python" = "xyes"],