summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2014-03-24 20:07:42 +0100
committerLennart Poettering <lennart@poettering.net>2014-03-24 20:07:42 +0100
commit7f8aa67131cfc03ddcbd31c0420754864fc122f0 (patch)
tree656e59465be5daa450fa4d34dcf2cc3bf298bf93 /configure.ac
parent1cfc57e8847ab2b138e5a8fcff4f881b3b1a9b60 (diff)
core: remove tcpwrap support
tcpwrap is legacy code, that is barely maintained upstream. It's APIs are awful, and the feature set it exposes (such as DNS and IDENT access control) questionnable. We should not support this natively in systemd. Hence, let's remove the code. If people want to continue making use of this, they can do so by plugging in "tcpd" for the processes they start. With that scheme things are as well or badly supported as they were from traditional inetd, hence no functionality is really lost.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 0 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 3ced6cf3d..e95b682f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -431,32 +431,6 @@ fi
AM_CONDITIONAL(HAVE_XZ, [test "$have_xz" = "yes"])
# ------------------------------------------------------------------------------
-AC_ARG_ENABLE([tcpwrap],
- AS_HELP_STRING([--disable-tcpwrap],[Disable optional TCP wrappers support]),
- [case "${enableval}" in
- yes) have_tcpwrap=yes ;;
- no) have_tcpwrap=no ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --disable-tcpwrap) ;;
- esac],
- [have_tcpwrap=auto])
-
-if test "x${have_tcpwrap}" != xno ; then
- ACX_LIBWRAP
- if test "x${LIBWRAP_LIBS}" = x ; then
- if test "x$have_tcpwrap" = xyes ; then
- AC_MSG_ERROR([*** TCP wrappers support not found.])
- fi
- have_tcpwrap=no
- else
- M4_DEFINES="$M4_DEFINES -DHAVE_LIBWRAP"
- have_tcpwrap=yes
- fi
-else
- LIBWRAP_LIBS=
-fi
-AC_SUBST(LIBWRAP_LIBS)
-
-# ------------------------------------------------------------------------------
AC_ARG_ENABLE([pam],
AS_HELP_STRING([--disable-pam],[Disable optional PAM support]),
[case "${enableval}" in
@@ -1130,7 +1104,6 @@ AC_MSG_RESULT([
$PACKAGE_NAME $VERSION
libcryptsetup: ${have_libcryptsetup}
- tcpwrap: ${have_tcpwrap}
PAM: ${have_pam}
AUDIT: ${have_audit}
IMA: ${have_ima}