summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChengwei Yang <chengwei.yang@intel.com>2014-01-15 13:06:00 +0800
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-01-16 00:16:02 -0500
commit8114dedc5910d9a9cec702f6b6658551a0cd9ede (patch)
tree14548d85fd78e11603d9caa4a7c9bf0f46d66fa9 /configure.ac
parent4f882b2a5007e51032459e29d15a86df6b5ea9f4 (diff)
build-sys: fix --enable-dbus
The incorrect shell code of AS_IF always get false value, so it always build without dbus though build with "--enable-dbus" explicitely.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 714062724..939ba6dcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -249,7 +249,7 @@ m4_pattern_forbid([^_?PKG_[A-Z_]+$],[*** pkg.m4 missing, please install pkg-conf
# ------------------------------------------------------------------------------
have_dbus=no
AC_ARG_ENABLE(dbus, AS_HELP_STRING([--disable-dbus], [disable usage of dbus-1 in tests]))
-AS_IF(["x$enable_dbus" != "xno"], [
+AS_IF([test "x$enable_dbus" != "xno"], [
PKG_CHECK_MODULES(DBUS, [dbus-1 >= 1.3.2],
[AC_DEFINE(HAVE_DBUS, 1, [Define if dbus-1 library is available]) have_dbus=yes],
[have_dbus=no])